Thread
#prefect-community
    f

    FuETL

    7 months ago
    Hey guys i getting this error while running my flow. Is there something i can look up to verify this error? I'm using the correct images from docker
     Failed to load and execute Flow's environment: StorageError('An error occurred while unpickling the flow:\n  ModuleNotFoundError("No module named 'testing_flow'")\nThis may be due to one of the following version mismatches between the flow build and execution environments:\n  - cloudpickle: (flow built with '2.0.0', currently running with '1.6.0')\n  - python: (flow built with '3.9.7', currently running with '3.7.10')\nThis also may be due to a missing Python module in your current environment. Please ensure you have all required flow dependencies installed.')
    Kevin Kho

    Kevin Kho

    7 months ago
    The Flow registration versions need to match the execution for Python, cloudpickle, and Prefect because there is serialization and deserialization, and having different versions will break this
    f

    FuETL

    7 months ago
    Yeah but i using an image that use the python 3.9, there this 3.7 come from? That's the issue.
    Kevin Kho

    Kevin Kho

    7 months ago
    From the base Prefect image if you use something like Docker storage or DockerRun
    You can just specify the python 3.9 image as your base image
    Can you show me your Storage and RunConfig?
    f

    FuETL

    7 months ago
    Let me try something, just one sec.
    Yeah i was passing the wrong DOCKER_IMAGE parameter to ECSRun
    Thank you @Kevin Kho
    Kevin Kho

    Kevin Kho

    7 months ago
    Ah gotcha. Of course!