Amichai Ben Ami

    Amichai Ben Ami

    7 months ago
    Hi, I am trying to run prefect on azure AKS. we are using Helm, but not using Postgres subchart, but external postgres. it used to work until few days ago. when installing it we get in graghql
    db-upgrade] Error applying Hasura metadata from /prefect-server/services/hasura/migrations/metadata.yaml
    I could not find anything that changed from our side. any idea? Thanks 🙏
    full logs
    [prefect-graphql-d64dd8658-xvl69 db-upgrade]
    [prefect-graphql-d64dd8658-xvl69 db-upgrade] Running Alembic migrations...
    [prefect-graphql-d64dd8658-xvl69 db-upgrade] INFO  [alembic.runtime.migration] Context impl PostgresqlImpl.
    [prefect-graphql-d64dd8658-xvl69 db-upgrade] INFO  [alembic.runtime.migration] Will assume transactional DDL.
    [prefect-graphql-d64dd8658-xvl69 db-upgrade]
    [prefect-graphql-d64dd8658-xvl69 db-upgrade] Error applying Hasura metadata from /prefect-server/services/hasura/migrations/metadata.yaml
    [prefect-graphql-d64dd8658-xvl69 db-upgrade]
    [prefect-graphql-d64dd8658-xvl69 db-upgrade] Could not upgrade the database!
    [prefect-graphql-d64dd8658-xvl69 db-upgrade] Error: Failed to apply Hasura metadata! Error: 400 Client Error: Bad Request for url: <http://prefect-hasura.prefect:3000/v1/query>
    Kevin Kho

    Kevin Kho

    7 months ago
    Hi @Amichai Ben Ami, there was an upgrade to Hasura 2.0 so this looks like the GraphQL pod may have upgraded and became incompatible with the Hasura pod. You need to upgrade. See this thread