https://prefect.io logo
Title
j

J.R. Carneiro

10/08/2020, 11:02 PM
Hi, I am having a dependency issue and I am unsure whether anyone has encountered this before
n

nicholas

10/08/2020, 11:03 PM
Hi @J.R. Carneiro - would you mind moving your error trace into this thread? At the moment it takes up a lot of space and prevents other questions from being seen.
j

J.R. Carneiro

10/08/2020, 11:05 PM
sorry
n

nicholas

10/08/2020, 11:07 PM
No worries @J.R. Carneiro - Just remove it from the original message and paste it as a reply here instead ūüôā
j

J.R. Carneiro

10/08/2020, 11:08 PM
from prefect import task, Flow, Parameter, unmapped  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/prefect/__init__.py", line 9, in <module>   import prefect.triggers  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/prefect/triggers.py", line 48, in <module>   from prefect.engine import signals  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/prefect/engine/__init__.py", line 8, in <module>   from prefect.engine.flow_runner import FlowRunner  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/prefect/engine/flow_runner.py", line 15, in <module>   from prefect.core import Edge, Flow, Task  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/prefect/core/__init__.py", line 4, in <module>   from prefect.core.flow import Flow  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/prefect/core/flow.py", line 41, in <module>   from prefect.environments import Environment  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/prefect/environments/__init__.py", line 1, in <module>   from prefect.environments.execution import (  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/prefect/environments/execution/__init__.py", line 8, in <module>   from prefect.environments.execution.dask import DaskKubernetesEnvironment  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/prefect/environments/execution/dask/__init__.py", line 2, in <module>   from prefect.environments.execution.dask.cloud_provider import (  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/prefect/environments/execution/dask/cloud_provider.py", line 5, in <module>   from distributed.deploy.cluster import Cluster  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/distributed/__init__.py", line 3, in <module>   from .actor import Actor, ActorFuture  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/distributed/actor.py", line 6, in <module>   from .client import Future, default_client  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/distributed/client.py", line 43, in <module>   from .batched import BatchedSend  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/distributed/batched.py", line 8, in <module>   from .core import CommClosedError  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/distributed/core.py", line 20, in <module>   from .comm import (  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/distributed/comm/__init__.py", line 1, in <module>   from .addressing import (  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/distributed/comm/addressing.py", line 5, in <module>   from ..utils import get_ip_interface  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/distributed/utils.py", line 97, in <module>   mp_context = _initialize_mp_context()  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/distributed/utils.py", line 88, in _initialize_mp_context   importlib.import_module(pkg)  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/importlib/__init__.py", line 127, in import_module   return _bootstrap._gcd_import(name[level:], package, level)  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/numpy/__init__.py", line 286, in <module>   raise RuntimeError(msg) RuntimeError: Polyfit sanity test emitted a warning, most likely due to using a buggy Accelerate backend. If you compiled yourself, see site.cfg.example for information. Otherwise report this to the vendor that provided NumPy. RankWarning: Polyfit may be poorly conditioned
n

nicholas

10/08/2020, 11:08 PM
Much appreciated ūüĎć
Looking at your error, do you have some code you can share? That looks very specific to a library and not prefect