k

    Keat

    1 year ago
    Hi all, So I started server on an ec2. With config.toml
    graphql_url
    pointing to
    backend = "server"
    graphql_url = "<http://localhost:4200/graphql>"
    [server]
      [server.ui]
      graphql_url = "<http://localhost:4200/graphql>"
    When I SSH-ed into the ec2 I have two portforward, 4200 and 8080. And my local
    config.toml
    has the same config as the server
    config.toml
    A local agent is running on the ec2. The issue I am facing is: When running the flow after registering from both local or in the ec2 instance, the shell tasks run into
    requests.exceptions.ReadTimeout: HTTPConnectionPool(host='localhost', port=4200): Read timed out. (read timeout=30)
    I reckon is my config.toml but not sure where to start, or is there something that I am missing ?
    nicholas

    nicholas

    1 year ago
    Hi @Keat - which version of Prefect are you using on your ec2?
    k

    Keat

    1 year ago
    Oops they’re both running on
    0.13.10
    both local and server
    nicholas

    nicholas

    1 year ago
    Got it - for 0.13.0 the correct
    server.ui
    endpoint variable is
    apollo_url
    (this was a correction from earlier versions which used
    graphql_url
    ). Are you able to pull up the UI?
    Can you share your flow code as well?
    k

    Keat

    1 year ago
    backend = "server"
      [server]
        [server.ui]
        apollo_url = "<http://localhost:4200/graphql>"
    The settings now for both
    Thanks @nicholas turned out it could be just the ec2 size being too small to handle one flow. 😆
    Felix V

    Felix V

    1 year ago
    I am running into the same issue. what did you end up doing?
    k

    Keat

    1 year ago
    @Felix V I just increased my ec2 size to
    small
    and it worked 😆