Thread
#prefect-server
    d

    Dana Merrick

    1 year ago
    I'm having trouble connecting to graphql via the Prefect Server webUI. I can reach it on localhost:4200, <ip>:4200, and <fully-qualified-name>:4200, but I always get
    Oops! It looks like something went wrong when trying to connect; make sure Prefect Server is running at the URL above and try again.
    Kyle Moon-Wright

    Kyle Moon-Wright

    1 year ago
    Hey @Dana Merrick, Tough to say exactly where the issue lies, but you can configure your GQL endpoint directly in the UI (under the Getting Started option at the top and clicking the Prefect Server tab) or by setting this endpoint directly in a config.toml file as described here.
    d

    Dana Merrick

    1 year ago
    yeah, so, I get to that page but whatever value I put in there gives me the same error
    Kyle Moon-Wright

    Kyle Moon-Wright

    1 year ago
    Hmm, are the backend services running and are they accessible via network configurations?
    d

    Dana Merrick

    1 year ago
    what do you mean by network configurations?
    as mentioned in OP, i can curl localhost:4200 from the box and get graphql to respond
    I can also curl <ip>:4200 and get the response, and also <fully-qualified-name>:4200
    so it's clear the graphql server is running and returning responses
    I read through old comments in slack and tried increasing my instance size (running on EC2), but that didnt help
    Kyle Moon-Wright

    Kyle Moon-Wright

    1 year ago
    Definitely strange you are unable to connect the endpoints despite healthy responses. If you are on the latest version of Prefect, I think the best resource here is

    this livestream

    on configuring Server and its individual services.
    d

    Dana Merrick

    1 year ago
    aight ill give that a shot
    when I get a connection failure on the prefect UI, where is that connection being made from? my browser to the graphql server? or the prefect server to graphql?
    Kyle Moon-Wright

    Kyle Moon-Wright

    1 year ago
    If the error is coming from the UI, then the browser is unable to connect with the GQL server.
    d

    Dana Merrick

    1 year ago
    so graphql needs to be exposed to all clients of the prefect server?
    Kyle Moon-Wright

    Kyle Moon-Wright

    1 year ago
    Also, the relevant part of that video for you will likely be around the 29 min mark, when Laura starts to connect Server services independently.
    I think this diagram will help show which service is connecting to what, but that video really dives into it.
    d

    Dana Merrick

    1 year ago
    is apollo running on 8080 after running
    prefect sever start
    ? or is that the UI?
    Kyle Moon-Wright

    Kyle Moon-Wright

    1 year ago
    Yes and all default settings are configured using the default config.toml file which can be overridden to meet your needs with a custom TOML file.
    d

    Dana Merrick

    1 year ago
    is there advice on setting up a load balancer (for me an ELB) in front of the UI? i think thats the root of my connection issues
    Kyle Moon-Wright

    Kyle Moon-Wright

    1 year ago
    Hmm, nothing official besides “you probably should go with Prefect Cloud” - Server wasn’t intended for Production setups with this level of configuration, so only experience can guide us here.
    d

    Dana Merrick

    1 year ago
    ah okay fair