Vladislav Bogucharov

04/21/2021, 4:14 PM
Hello everyone! I am trying to install prefect according to the tutorial, I run the following commands:
python3 -m venv prefect_venv
source prefect_venv/bin/activate
pip install wheel
pip install prefect
prefect backend server
prefect server start
And then I get the error: subprocess.CalledProcessError: Command '[' docker-compose ',' down ']' returned non-zero exit status 255. When I run
prefect diagnostics
everything seems to be fine:
  "config_overrides": {},
  "env_vars": [],
  "system_information": {
    "platform": "Linux-4.15.0-142-generic-x86_64-with-Ubuntu-18.04-bionic",
    "prefect_backend": "server",
    "prefect_version": "0.14.16",
    "python_version": "3.6.9"
Has anyone faced this problem?

Chris White

04/21/2021, 4:16 PM
Hi Vladislav - if you search GitHub you can usually find discussions around errors like this: In this case it’s most likely because you don’t have either Docker or docker-compose running on your machine

Vladislav Bogucharov

04/21/2021, 4:20 PM
Thanks, but I have a slightly different problem. I suspect there is an access issue. Because I see the following messages in error: docker.errors.DockerException: Error while fetching server API version: ('Connection aborted.', PermissionError (13, 'Permission denied'))
Ok, it seems that everything works as it should under root.