https://prefect.io logo
#prefect-server
Title
# prefect-server
j

Jeevan Acharya

09/01/2021, 2:56 PM
Hi Everyone 👋 I have setup the prefect server in a kubernetes cluster using Helm Chart (https://github.com/PrefectHQ/server/tree/master/helm/prefect-server) I have also set up ingress rules for the UI and apollo components. Unfortunately the UI page is not loading, i am able to access apollo though. I have created the tenant as mentioned in the docs using '--set jobs.createTenant.enabled=true' and also directly using graphql mutation. Any idea what might be the issue?
k

Kevin Kho

09/01/2021, 3:02 PM
Hey @Jeevan Acharya, are you trying to access the UI from a different machine or the same machine? On the same machine, do you see it if you go to
localhost:8080
?
j

Jeevan Acharya

09/01/2021, 3:10 PM
Hi Kevin, im trying to access it from a different machine which to www.example.com which is mapped to localhost
I'm able to access the UI, but it just shows a loading page, i cant see the dashboard or anything else
k

Kevin Kho

09/01/2021, 3:15 PM
Does it work fine on the localhost?
j

Jeevan Acharya

09/01/2021, 3:25 PM
it did not, as far as i remember. Let me try again without the ingress and get back
k

Kevin Kho

09/01/2021, 3:27 PM
Did you configure you UI like this ?
j

Jeevan Acharya

09/01/2021, 3:34 PM
We have a prefect infrastructure running locally using the above configuration, but now we are trying to use Helm charts to deploy it on the k8s cluster
the local server and ui works fine
k

Kevin Kho

09/01/2021, 3:37 PM
Did you do this?
👍 1
j

Jeevan Acharya

09/01/2021, 3:43 PM
seems to be a similar issue, but I have edited https://github.com/PrefectHQ/server/blob/fddd6c8c5e433891dfb91b3ef9d24ad9295d47cd/helm/prefect-server/values.yaml#L253 to the correct value. Also logged into the running UI container and curl on apolloApiUrl( i'm able to access this from my browser) works.
k

Kevin Kho

09/01/2021, 3:54 PM
From the machine where you are connecting, did you set the URL like this inside your
config.toml
?
Or
Copy code
[server]
endpoint = "YOUR_MACHINES_PUBLIC_IP:4200/graphql"
and then
prefect backend server
j

Jeevan Acharya

09/01/2021, 4:56 PM
seems like its still not working
k

Kevin Kho

09/01/2021, 5:13 PM
Will ask someone from the team who can help with this better.
There are a couple troubleshooting steps there but it looks like you've covered it here. Maybe how it's explained there will be helpful though.
Since you've said you can exec into the UI container and curl the API url, it's really important to note that the API url needs to be curlable from your machine not the UI container.
The value that you set the API url to needs to be whatever the user would need to curl the API or access it in their browser
j

Jeevan Acharya

09/01/2021, 5:45 PM
Hi Michael, I have followed the troubleshooting steps, with no success. curl from both the container and my machine works, however <ui_url>/settings.json still gives the loading page content. We have a dev vm on which we are running prefect( installed using docker-compose). We use the same dev vm to run Helm commands to deploy to our isolated k8s cluster. Since we already have prefect installed maybe its interfering with 'helm install <chart>'.? I'll pull down all our prefect related stuff and start from scratch
z

Zanie

09/01/2021, 5:46 PM
A prefect installation shouldn't have any affect on a helm install.
👍 1
cc @Jenny for any advice on investigation on the UI side
j

Jenny

09/01/2021, 6:42 PM
Hi @Jeevan Acharya - if you're still having issues could you share what you mean by "loading page" - is it the one with the blue dots or the dashboard page with a skeleton loader? Can you also check whether you have a VUE_APP_BACKEND variable set anywhere. That will need to be set to SERVER.
j

Jeevan Acharya

09/01/2021, 7:46 PM
Hi Jenny, its the one with the blue dots
I dont have VUE_APP_BACKEND set anywhere. Where exactly should i set it? and what should be the value?
z

Zanie

09/01/2021, 7:48 PM
That should be set in the UI container by the chart, I believe.
It's not actually.. are you sure about that Jenny?
j

Jenny

09/01/2021, 7:56 PM
It's set in the UI and the default is SERVER so unless you've changed something (and it sounds like you haven't) it should be correct.
And double checking you're not an older version of the UI? We had an issue with the 0.15.3 Perfect version that sounds similar.
👍 1
5 Views