Hi, it seems prefect-server broke on my end. Whene...
# prefect-server
Hi, it seems prefect-server broke on my end. Whenever I access my public EC2 IP Address, on port 8080 I get "Unable to connect". My security group is already well configured (I tried it with a simple
python -m http.server 8080
and it worked perfectly fine) so it seems to be an issue with prefect server, the thing is I changed absolutely nothing, when the server is running, I can do a
wget localhost:8080
and get the prefect UI html with no issue, same thing, I can register a flow with no issue. It simply seems to be a connectivity issue between the outside world and my prefect server, despite both 8080 and 4200 ports being opened on EC2
I should note that trying to acces
(not opened port) I wait for a bit before getting a "connection timed out", contrary to what happens with
or ``public_ip:8080`` which results in a quick response of "Unable to connect"
Even if I run with -v core-0.15.3 and -uv core-0.15.3 it still doesn't work, so it's neither my security groups, neither something that changed within prefect server recently, I'm at loss
Hey @Hugo Polloli -- I bet you're missing the
flag. See https://github.com/PrefectHQ/prefect/blob/master/CHANGELOG.md#breaking-changes
upvote 1
Ooooooh damn, I'm going to try that but it has to be it
Thanks a lot it's exactly that ! I tried older versions of the images, but not of prefect itself so I was looking in the wrong place my bad !