Thread
#prefect-server
    Will Skelton

    Will Skelton

    9 months ago
    Hi all, I'm working through the getting-started tutorial but have run into an issue running the first basic flow. I'm trying to run the script in jupyter but the "import prefect" is failing. I went to my prefect virtual python environment and tried to get confirmation of the prefect version I have installed and I get an error when I run "prefect --version" (I guessed that this was how to see if prefect was installed successfully) . Here is the error. Any thoughts on beginning to troubleshoot this? I also tried "prefect server start" and got the same error. Thanks!
    Kevin Kho

    Kevin Kho

    9 months ago
    Hi @Will Skelton, how did you install Prefect? Just
    pip install prefect
    ?
    Anna Geller

    Anna Geller

    9 months ago
    @Will Skelton it looks like a urllib3 version mismatch between what your Prefect and bitbucket packages require. I would try reinstalling prefect in a fresh new virtual environment using:
    pip install "prefect[bitbucket]"
    (assuming that you need bitbucket)
    Will Skelton

    Will Skelton

    9 months ago
    @Kevin Kho, and @Anna Geller I first tried "pip install prefect" and got some errors... so then I used conda and it completed without errors. I went ahead an removed it (via conda), and re-installed including the bitbucket package (via conda) and now am getting responses with "prefect -h" and "prefect version" Thanks!