Thread
#prefect-server
    Will Skelton

    Will Skelton

    8 months ago
    I'm trying to get the UI running locally to enable a better view into what is happening in prefect during my POC/development. When running "prefect server start" I get the following error. I do have a local install of postgres already that could be causing this. Any thoughts here? I didn't see anything in the troubleshooting docs or the github discussions area.
    Kevin Kho

    Kevin Kho

    8 months ago
    If you are saying the ports are blocked for use, maybe you can use different ports. If you want to use that postgres instance, you can do it like this
    Will Skelton

    Will Skelton

    8 months ago
    Thanks @Kevin Kho, That got me so the UI is loaded bu tteh GraphQL endpoint isn't playing along now. (Same thing happens when using port 4200)
    It might still be the database... Looking further.
    Kevin Kho

    Kevin Kho

    8 months ago
    Just wanted to make sure you’re aware Prefect Cloud gives 20k task runs for free per month right? It’s a lot easier to do a POC with if you’re able to. I understand some companies are strict about it
    Will Skelton

    Will Skelton

    8 months ago
    Yes, I saw. I think working my way through these errors will help the POC in the long run. I'm learning too 🙂
    Kevin Kho

    Kevin Kho

    8 months ago
    Uhh not particularly cuz we host it all for you 😆
    Will Skelton

    Will Skelton

    8 months ago
    We'll need to host it.
    Kevin Kho

    Kevin Kho

    8 months ago
    Ah I see
    Will Skelton

    Will Skelton

    8 months ago
    I wasn't able to get the external postgres server to work (could be a docker desktop exposure issue?) but was able to change the default port for the postgres server that prefect creates and now I'm seeing the dashboard!
    Kevin Kho

    Kevin Kho

    8 months ago
    It could be yeah