Bradley Hurley

    Bradley Hurley

    8 months ago
    Hi - I've encountered an issue, but I'm not sure its a bug because my situation is unique. Because of the upcoming license changes to Docker Desktop I have configured my local machine to use the Docker daemon on a VM thats already running on my local machine to support microk8s. When attempting to run a docker agent I encountered issues related to
    host.docker.internal
    . I dug into the source and realize the IP only gets set properly if the
    sys.platform
    starts with
    linux
    . My host machine is OSX, but docker is running on Linux. Here is my prefect agent start command
    prefect agent docker start -b <tcp://192.168.64.2:2375> -l bh-docker --network prefect-server --log-level DEBUG --show-flow-logs --no-pull
    locally I run
    export DOCKER_HOST=<tcp://192.168.64.2:2375>
    and then docker works as if it was running on my local machine
    Kevin Kho

    Kevin Kho

    8 months ago
    Thanks for sharing! I don’t think we consider this a bug, but it’s great to learn from your experience!
    Bradley Hurley

    Bradley Hurley

    8 months ago
    Its kind of strange behavior since the agent supports running on a docker daemon that is not physically local to the machine with the
    -b
    flag, but outside adding a new cli option Im not sure there is a great solution.