Thread
#prefect-ui
    p

    P Money

    1 year ago
    Hi. 🙂 I've created a flow that I want to schedule using the UI. However whenever I create a schedule it keeps disappearing. Do you have any idea what I'm doing wrong? Thanks for you help! 😄
    Jenny

    Jenny

    1 year ago
    Hi @P Money - can you give a bit more information about this so we can try recreate? Is this is server or cloud? Do you see any error messages when you try to create the schedule? What type of schedule are you creating? (Are you clicking on advanced or adding parameters?) Thanks!
    p

    P Money

    1 year ago
    Hi @Jenny, Thanks. I'm very new to all this 😄 I'm using Prefect Cloud and want to create a schedule so my program runs 09:00 AM CEST every day. So far I have not been clicking on the advanced parameters. I don't get any error messages but my schedule just disappears right after creating it.
    m

    Mariia Kerimova

    1 year ago
    Hello @P Money! Does your flow contains any Parameters?
    p

    P Money

    1 year ago
    Hi 🙂 Yes it has one optional parameter. The parameter should just be the default value (i.e. I don't want to set it) for the scheduled run.
    It seems like the issue is I have a non-required parameter in my flow
    x = DateTimeParameter("x_name", required=False)
    I don't want to set the parameter in my schedule - it should just be the default value
    m

    Mariia Kerimova

    1 year ago
    Hello @P Money! I apologize for late reply. I think you might found a bug, let me test it my theory, and I'll get back to you.
    p

    P Money

    1 year ago
    Thanks at lot for your help @Mariia Kerimova 😃
    m

    Mariia Kerimova

    1 year ago
    Hello! I was able to reproduce the error. If you set default value for Parameter like this:
    name = Parameter("name", default="TEST", required=False)
    it works perfectly, but when if you omit the default parameter, it sets all defaults to null, which is going to give you a Graphql error.
    I opened this issue https://github.com/PrefectHQ/ui/issues/765 Thank you so much for reporting this bug!
    p

    P Money

    1 year ago
    Thanks for getting to the bottom of this, Marria! Hopefully the bug will be fixed soon then 🙂
    n

    Natalie Smith

    1 year ago
    Hi P Money. We have released an update for this and now you shouldn't see any issues when creating schedules from the UI
    p

    P Money

    1 year ago
    Great - thanks Natalie! It works. I can schedule my flow now 😄