Sorry for a dumb question but I am at a dead end. ...
# prefect-ui
Sorry for a dumb question but I am at a dead end. what thing tells the UI that it should redirect you to the Cloud login? I have something cached somewhere or configured wrong but I have not a clue. Its configured using [this config]( I've run it on a different server and it works. I've tried both Firefox and Brave. Tried looking at browser cache to see if anything stands out but it keeps saying can't find the User and will either redirect me to an Oath page or just be a blank white page some console errors saying it can't find a user.
Hi @Matt Camp - not a dumb question at all! Do you have the latest version of the repo you referenced? I believe it got the same error:
And then was updated to use an older version of the UI:
yea I'd imagine its the latest.. I did a clone of it alittle while ago.. and have actually since morphed it all into my own config now. The absolute craziest thing is the EXACT same config works on another computer on my network perfectly but not on my current laptop. When I say EXACT same config I mean I have Syncthing syncing the folder that has all ofthe
stuff in it
Hmmmm.... have you used Cloud at all on that laptop? Can you try setting VUE_APP_BACKEND=SERVER
hmm thanks I'll compare what I've got with the latest and see ifI can spot the problem
no never used cloud
but I'll add the to the UI container?
One more thought - if you're able to tell which image you're using to build the UI check to see if it's earlier than 2021-04-15. If it is, you may also be able to use local storage to set the backend.
originally it was latest, but I just "updated" it back to the "2021-02-23" image..
odd so its working now.. but I definitely have some caching issue, cause i have to access it with my hostname instead of localhost.
Ah yes sorry - when I said latest I meant using the older version of Prefect. We made some updates to the cloud auth that look like they've affected custom builds of server so the older version should work. Glad you got it figured out.
For upcoming users getting this problem at the moment : 1. Use the Prefect UI image
2. Clear your browsing data (cache and cookies). You might want to use a different browser for checking the access works.
Just want to mention I was bitten by this, fixed by clearing existing containers out and re-pulling latest from docker, as well as clearing browser data for my domain with prefect ui deployed. Bit of a pain...
👍 1