d

    David Beck

    6 months ago
    Hi Prefect Team! I'm looking to disable cloud logging since our implementation will be routing our logs via k8s directly to splunk. I tried setting an env value of
    PREFECT__CLOUD__SEND_FLOW_RUN_LOGS=False
    in our global container config which I see being recognized by Prefect Cloud, however there are logs still populating for the run (see attached). Do I perhaps have the wrong value defined or could I be missing something?
    Kevin Kho

    Kevin Kho

    6 months ago
    That looks right so confused why it’s behaving like that. I can ask the team but you can also try the
    --no-cloud-logs
    on the agent when you start per this
    d

    David Beck

    6 months ago
    @Kevin Kho okay I thought I set that up correctly. Please let me know what the team says. I have to look into our CI/CD process to see if/how we can include that run flag. We are submitting scheduled flow runs, so I'd have to be sure that they are receiving the
    --no-cloud-logs
    flag
    Michael Adkins

    Michael Adkins

    6 months ago
    Hey David, the agent overrides this environment variable value with its own setting.
    I’d accept a pull request to change this behavior to allow override as you’ve done. This isn’t intended behavior.
    Anna Geller

    Anna Geller

    6 months ago
    @Marvin open "Allow disabling sending flow run logs on a per flow run basis via PREFECT__CLOUD__SEND_FLOW_RUN_LOGS environment variable"
    Marvin

    Marvin

    6 months ago
    d

    David Beck

    6 months ago
    Thanks @Michael Adkins & @Anna Geller! I will follow that issue request and look to the work around for
    --no-cloud-logs
    in the mean time.