Hi Prefect Community, i am facing the following is...
# prefect-community
c
Hi Prefect Community, i am facing the following issue:
(begin_task_run pid=81126)     from prefect.packaging.docker import DockerPackager
(begin_task_run pid=81126) ImportError: cannot import name 'DockerPackager' from partially initialized module 'prefect.packaging.docker' (most likely due to a circular import) (/home/christian/Documents/ray_and_prefect/temp/temp-venv/lib/python3.9/site-packages/prefect/packaging/docker.py)
Which is similar to this already existing ticket + discussion: https://github.com/PrefectHQ/prefect/issues/5976 Do you have any idea what could be the reason?
As suggested in the ticket I am running prefect and prefect-ray as latest versions from the github repos directly
t
Hi Christian 🙂, I am not sure what is causing your error, but as an fyi, FilePackagers and FlowRunners have been deprecated since GA replaced by storage blocks and infrastructure blocks. We recommend upgrading your prefect version so that you are no longer using the beta version.
c
Hi Taylor, thanks for your response. Sorry, my thread was a bit unclear. I'm actually running on the latest versions (as you also suggest). The ticket is only showing a similar behavior from an older version, thats why I referenced it.
t
Ah, ok. thank you for sharing this error. Could you describe what lead to the error? Did you run
deployment build
, is this the error you are seeing when the flow runs?
c
I am seeing the error when pulling the work from the queue and trying to run the flow.
t
So you are able to run
prefect agent start
successfully?
1
I have flagged this to Anna since she has helped you with a similar error. 🎏
c
yea thanks a lot
a
packagers are gone
don't use them we'll provide guidelines on packaging but it will not use the same packagers as in beta
t
Have you updated your deployments since upgrading to the most recent version of prefect? Have you tried building deployments with storage blocks for flow code storage?
c
Yep, updated my deployment and used s3 for flow code storage. The code is also visible in the bucket.
I am not using a packager in my flow nor deployment, so I am a bit confused. I rather thought I messed up the dependencies since its mentioning a circular import error.
🤔 1
a
have you solved it? if not, can you share a minimal reproducible example?
you can share a simple repo with your project, would make it easier to troubleshoot also sharing the output of
prefect version