We created a deployment: `<https://app.prefect.clo...
# prefect-community
We created a deployment:
- it has the
tag. We have a running agent:
Copy code
$ /usr/bin/python3 /usr/local/bin/prefect agent start 360***
Starting agent connected to 
  ___ ___ ___ ___ ___ ___ _____     _   ___ ___ _  _ _____
 | _ \ _ \ __| __| __/ __|_   _|   /_\ / __| __| \| |_   _|
 |  _/   / _|| _|| _| (__  | |    / _ \ (_ | _|| .` | | |
 |_| |_|_\___|_| |___\___| |_|   /_/ \_\___|___|_|\_| |_|
Agent started! Looking for work from queue 
The work queue also has the tag
. When I click on "Run" in the Cloud UI in the deployment, it is scheduled but the flow run has no tags assigned. And I guest this is the reason why it is never picked up by the agent. Or how can I debug this issue?
Hi Tim 🙂 You have identified a UI bug that we should have fixed by the next release. (That in the flow run details, a deployment’s tags are not shown.) However, the UI bug should not affect the work-queue’s ability to identify a deployment with the right tags. It is a UI issue. That being said… The tag matching for deployment-worqueues is AND not OR based which means that you need to ensure that the work-queue lists ALL the tags that your deployment has.
🙌 1
So one question I have is, what are the tags are the deployment you are trying to run and what are the tags of the workqueue that’s the agent in question is polling?
Thanks for the information! Both, so the queue and the deployment only have the
tag and nothing else.
🤔 1
What version of prefect are you using?
I’m curious if you try to create a new workqueue from the cli by running a tag-based agent like I think the command is:
prefect agent start --tag staging
2.0.1. We just upgraded to 2.0.2 but can only test the new version later. I will try out both, so upgrading to 2.0.2 and the new command. I will report back if it worked. Thanks!
try the new command
then upgrading, but actually don’t think upgrading will help in this case if you are already .1
lmk what happens when you run
prefect agent start --tag staging
and then try to re-run the deployment from UI
👌 1
Thanks, this worked!
blob attention gif 1