Hi, Community, I tried to follow the tutorial of P...
# prefect-community
Hi, Community, I tried to follow the tutorial of Prefect Cloud 2.0. I could run the flow locally and saw the flow run results right there in Prefect Cloud. However, when I created a flow run from my deployment on the cloud, the local terminal session didn't pick up the flow run and kept showing the error below. Any help will be appreciated!
can you share the actual traceback? 😄
definitely worth recreating your environment, creating a new API key, relogging in, recreate deployment and perhaps it works then? check this example https://github.com/anna-geller/prefect-deployment-patterns/tree/main/a_project_template
I had a similar issue with local agent not picking up cloud flows. I took Anna's advice and started the tutorial over in a new environment, also went to the UI and deleted all keys, work-queues, and flows created on previous 2.0b beta versions, and now it works.
👍 3
Nice work, Benny!
@Anna Geller Here's my traceback. Thank you
@Anna Geller Hi Anna, I recreated a virtual environment, reinstalled prefect 2.0, generated a new API key, and related a new deployment. I'm still getting the same error message. Thank you
do you have an option to try that in a Linux environment? or on Windows in WSL?
@Anna Geller Hi Anna, it works now! it was because the antivirus software installed on my company laptop prevents Prefect Cloud from connecting to the local agent.
🙌 1
thank you
thanks for the update!