https://prefect.io logo
Title
r

Riccardo Tesselli

07/27/2022, 8:59 AM
hi there. Iā€™m running Prefect 2.0 on beta cloud. Since this morning I receive this error when submitting jobs to K8s:
Response: {'detail': 'The request specified API version 0.7.0 but this serverrequires version 0.8.0 or higher.'}
btw Iā€™m using default image for KubernetesJob and my code is up to date with version
2.0b15
āœ… 1
āž• 2
b

Benjamin.bgx

07/27/2022, 9:15 AM
Same here šŸ˜›
Hey @Riccardo Tesselli, juste upgrade to the last version prefect on your computer, agent, etc !
My agent did not have the right version, but my pc was fine;
a

Andreas Nigg

07/27/2022, 11:18 AM
Can confirm what Benjamin mentioned. I also upgraded my agent to 2.0b15 and this message disappeared. šŸ‘
šŸ™Œ 3
r

Riccardo Tesselli

07/27/2022, 11:34 AM
In order to make it work I needed to re-create the deployment after the upgrade to 2.0b15
šŸŽ‰ 3
b

Benjamin.bgx

07/27/2022, 11:35 AM
Yes, with prefect all the version have to be sync. The one you compile, the one that execute, etc etc.
:gratitude-thank-you: 1
šŸ‘ 1
a

Andreas Nigg

07/27/2022, 11:40 AM
Ah ok makes sense, as the KubernetesJob deployment contains information about what image to use. Therefore it needs to be recreated. Subprocess runners I guess don't need to be recreated, as they run directly in the agent container. Thanks for the heads up, this clears up some clouds in my head šŸ‘
:thank-you: 1