Nick McGoye

08/29/2023, 2:46 PM
Hi Prefect Community: Curious if anyone has ever received this issue when deploying flows using the prefect.yaml method?
Copy code
(venv) pi@etlwizard:~/app/my_repo$ prefect deploy

? Would you like to use an existing deployment configuration? [Use arrows to move; enter to select; n to select none]
┃   ┃ Name                 ┃ Entrypoint                              ┃ Description ┃
│ > │ test-flow-deployment │ prod/testing/ │             │
    No, configure a new deployment

Expecting value: line 1 column 1 (char 0)

(venv) pi@etlwizard:~/app/my_repo$
No error message, nothing deployed.. Only:
Expecting value: line 1 column 1 (char 0)
I've tried resetting everything, reinitialized the repository. This looks like a json decode error but I'm not sure where in the process it would receive an empty response? Any places to look would be appreciated! This is using Ubuntu 20.04 and Prefect version 2.11.5. Any further information on tech stack or contents of the Prefect.yaml is something I can pass along if that helps.

Bianca Hoch

08/29/2023, 5:27 PM
Hi Nick, thanks for raising this. Have you checked the API key and URL of the prefect profile you're using when running
prefect deploy
? You can run
prefect profile inspect
to view them.
I'd make sure that the API key is valid, and the the URL is in the following format.
Copy code
Sometimes users realize the URL is set to instead of, which has been tied to this error previously. The next thing I'd confirm, if you're using Cloud, is that you have Developer permissions for the workspace you're deploying the flow to

Nick McGoye

08/30/2023, 2:05 PM
Thank you for the quick reply Bianca! My credentials expired according to the UI, and updating the environment variables seemed to work because the daemonized worker process I had running in the background was smooth sailing, and prefect profile inspect and validate worked, but the prefect deploy call didn't recognize the new credentials for some reason. The new credentials had full owner permissions to see if that was the issue but to no avail