Aaron Gee-Clough

07/23/2023, 6:46 PM
Hey, folks, on my continuing quest to install prefect-server in k8s, I've got the helm install (mostly) working, but the UI is reacting...weirdly. When I go to the exposed URL of the server, the settings page looks like this:
This is running container version
installed via a slightly-modified helm chart to get MetalLB exposure working
I'm also seeing a ton of 405-errors from the browser to the web ui
I presume there's some assumption about running the server component in k8s, but I'm not sure what it is at the moment.
just tried with version
and getting the same results.


07/25/2023, 2:43 AM
Did you try using port-forward to the service? That would rule out issues related to your ingress or load balancer

Aaron Gee-Clough

07/25/2023, 8:54 PM
I did. Doing it the naive way had the same result because the
was still pointed at the loadbalancer address. I re-installed it with the apiUrl and the apiHost set to
, tried the port-forward, and got the same thing.
My suspicion is that if the load balancer weren't working I wouldn't get any response, rather than an empty html file.
(especially since I'm doing this with MetalLB rather than ingress, so it's not trying to interpret the http)
Ugh. Apologies. I figured it out. For the record:
needs to end in
/api helm chart did not have that set properly, it just had the base url
. Hence the weirdness.