https://prefect.io logo
i

Ivan

07/21/2023, 1:37 PM
Hi team! Trying out the new ECS Push worker pool. But currently it fails, when I'm trying to run a deployment flow. 1. I’ve set work-pool from UI using the settings from screenshots 1-2 2. Tried to deploy a flow with a ECSTask Block call inside. a. When I'm running this deployment, it fails (screenshot 3). b. When I'm running this deployment but on the regular prefect worker, it works. (screenshot 5). The flow code is simple (screenshot 4). How to resolve that? Is there a way to get the logs of prefect cloud push worker (I'm not sure why the jobs keeps crashing)? Thank you for attention!
j

Jake Kaplan

07/21/2023, 1:39 PM
Hey, do you mind sharing your workspace id and flow run id?
i

Ivan

07/21/2023, 1:59 PM
Hi! I'm sorry, it seems that I've put an extra double-quote at the end of the IAM string... When I've fixed that and relaunched the job - it stuck in the "Pending" state. Will send you the link in DM.
Solved this issue. • there was a typo in the Task execution role • Image should contain a prefect agent worker image