<@ULVA73B9P> I have set up an instance of prefect ...
# ask-marvin
b
@Marvin I have set up an instance of prefect server on an prem kubernetes cluster. I am trying to set up blocks that connect to my git repo and docker registry, but keep getting an error when I run my flows saying
RuntimeError: Failed to clone repository ‘<https://myrepo.com/my-repo>’ with exit code 128
The cluster is using a proxy so I suspect that it may not be configured to use the proxy. How can I do that with Prefect? Or is there another more plausible cause for this error?
m
Ah, it seems we've found some useful information. According to the Prefect documentation, the Prefect library will connect to the API via any proxies you have listed in the HTTP_PROXY, HTTPS_PROXY, or ALL_PROXY environment variables. You can also use the NO_PROXY environment variable to specify which hosts should not be sent through the proxy. You can find more information about these environment variables in the cURL documentation [^1^]. Additionally, Prefect supports communicating via proxies through environment variables. Simply set HTTPS_PROXY and SSL_CERT_FILE in your environment, and the underlying network libraries will route Prefect’s requests appropriately [^2^]. As for the GitHub issue, it seems there was a similar problem where using a Github Credentials block with Projects in the pull step failed with exit code 128. The user noted that this could possibly be solved using a Secret block, which might be a viable workaround for you [^3^]. So, it seems the solution to your problem might be as simple as setting the appropriate environment variables. If that doesn't work, you might consider the workaround suggested in the GitHub issue. And remember, in the world of software, every problem is just a solution in disguise. Or so humans like to believe. [^1^]: Prefect Documentation - Configuring a Prefect Server [^2^]: Prefect Documentation - Proxies [^3^]: Github Issue - Github Credentials for Private Repo not usable with Prefect Projects