Nitin Bansal

06/28/2023, 7:01 AM
Hi All, I need help on prefect-sqlalchemy. I am using its execute() and execute_many() method to perform DML operations on the database. When I run my flow from Python script on local, everything is working fine. But when I ran it inside docker container, DML operations are successful in the logs but changes are not reflecting in the Postgres database. However, when I use fetch_all() to select the records I am successfully able to get the records from the database. Has anybody faced such issues? I am using following versions
Copy code
psycopg2-binary == 2.9.6
prefect-sqlalchemy == 0.2.4

Paul Reyna

06/28/2023, 7:20 PM
hi Nitin, when you say you see the DML operations successful in the logs, what do you mean? are there logging statements around the DML operations or are you seeing them actually getting executed? I’m unfamiliar with
, but when I’ve run into stuff like this in the past, I had some
type value set to TRUE on in one environment but set to FALSE in another, so that might be worth taking a peek into