Nicholas Torba

05/22/2023, 4:00 PM
Hello, I have a product work queue that has suddenly become unhealthy over the weekend. Nothing changed, except that the flow runs that are scheduled are not running. I run an agent for a single work pool, that has 2 different work queues. Anybody have this happen before? I have tried to copy them to new runs, as well as cancel and retry them, but neither of those options is getting picked up by my agent... this is v high priority for my team, so any help would be great
@Chris Reuter do you know anyone that can help me with this? I can't figure out why the agent won't pick up the jobs
👀 1
okay, so it looked like there was a single flow that was stuck in a long "running" state. I cancelled that one and other jobs are running, but for some reason the pool is only running a single job at a time, instead of 3, which is what my concurrency limit is set to


05/22/2023, 6:06 PM
Hi @Nicholas Torba - it looks like something is blocking your work-queues concurrency. There's a few things you can do there: • Look back in the UI for any runs associated with the work queue in a running or pending state. You should be able to do that from the work-queues tab. You can then decide to delete those runs or cancel them. • Clear your concurrency limit - you can use
prefect work-queue clear-concurrency-limit
from the cli
Let us know if that helps.