Leela Surya Teja Mangamuri

04/11/2023, 8:34 PM
Hello @Prefect, I am trying to create the service using. I am using python requests and running it in dokcer. I am getting this error. Could you please throw some light on this? :HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /api/accounts/{account_id}/bots/ (Caused by SSLError(SSLCertVerificationError(1, '[SSL : CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1131)')))

Carlos Cueto

04/12/2023, 4:41 AM
That sounds to me like a local issue within your network. Does your network use a proxy?

Leela Surya Teja Mangamuri

04/12/2023, 4:42 AM
It works fine when I run it locally. However, I am getting error when I run it with docker

Ryan Peden

04/12/2023, 5:25 AM
It looks like your Docker image is missing its CA certificates, or for some reason Python just can't find them. You could try setting an env variable like so:
export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
That works on Ubuntu, but other distros might work it as well. You could also try running `update-ca-certificates inside your container to see if that makes a difference

Leela Surya Teja Mangamuri

04/12/2023, 3:27 PM
Thank you. After exporting the ssl_cert_file, it is working.