• Michal Zawadzki

    Michal Zawadzki

    3 months ago
    FYI Something seems to have changed with the Docker image of the 2.0b7 release (
    prefecthq/prefect:2.0b7-python3.10
    to be exact); I was getting error code 255 at the
    apt-key add
    step in my custom image. Adding apt install gnupgfixed the issue.
    Michal Zawadzki
    Kevin Kho
    2 replies
    Copy to Clipboard
  • Constantino Schillebeeckx

    Constantino Schillebeeckx

    3 months ago
    is anyone having pretty major issues using the Web UI in firefox?
    Constantino Schillebeeckx
    Kevin Kho
    +3
    16 replies
    Copy to Clipboard
  • r

    rectalogic

    3 months ago
    we're no longer able to login via firefox or chrome. We login then get sent to https://cloud.prefect.io/access-denied In chrome sometimes it can't resolve cloud.prefect.io
    r
    Kevin Kho
    +1
    10 replies
    Copy to Clipboard
  • s

    Scott Aefsky

    3 months ago
    Hi all. I have a flow with the following tasks defined:
    capture_ID_batch, all_capture_metadata = get_unprocessed_capture_ID_batches(snowflake_tbl, experiment_id=10, batch_size = 500)
        capture_loc_map = get_locations_for_captures(all_capture_metadata, s3_bucket)
        #read the files from local disk given IDs, process and record proc jsons
        process_batch.map(capture_ID_batch, unmapped(snowflake_tbl), unmapped(capture_loc_map), unmapped(intrazone_extractor), unmapped(dynamic_zone_finder))
    The Prefect schematic shows that my first task get_unprocessed_capture_ID_batchesis getting duplicated, and my flow is eventually failing because of a Dask scheduler timeout. The last task starts running, but won't complete because the timeout kills it. I'm trying to understand a couple of things: • Why is my first task showing up as if it's a mapped task? • Why is the base node of that task not completing if each of the 2 instances of it are complete? • Why is the scheduler timing out? If I run this flow with a small amount of data, it runs fine, but with a larger dataset I get this failure. Thanks for any help you can provide!
    s
    Kevin Kho
    17 replies
    Copy to Clipboard
  • n

    Nicholas Kan

    3 months ago
    Hi Everyone, trying to set up prefect on my local machine for the first time, I keep getting this error when the postgres docker container is building. I am just using the docker-compose from docker hub. Has anyone encountered this before or knows how to workaround? Error message in the replies
    n
    Kevin Kho
    14 replies
    Copy to Clipboard
  • Javier Ochoa

    Javier Ochoa

    3 months ago
    Hello, I am trying to setup a prefect agent into AWS ECS task... it worked, but inside the python scripts this prefect agent is running, I am instancing a boto3 to talk to our SSM Parameters but I am getting an "AccessDenied" Error. It must be related to policies, but I have a hard time solving that issue (editing policies, editing roles... etc and still getting the same thing)
    botocore.exceptions.ClientError: An error occurred (AccessDeniedException) when calling the GetParameter operation: User: arn:aws:sts::999999999999:assumed-role/MyRole-dev/12345459ba45458183ed3d1aa5112341 is not authorized to perform: ssm:GetParameter on resource: arn:aws:ssm:region:999999999999:parameter/XXX/value because no identity-based policy allows the ssm:GetParameter action
    What is your suggestion here, or a possible solution for this?
    Javier Ochoa
    Kevin Kho
    12 replies
    Copy to Clipboard
  • j

    Jehan Abduljabbar

    3 months ago
    Hello, I have this problem when running a flow on the server using dask executer. (I don't have the problem when I use the server without dask, or when I use dask executer but use flow.run() from vs code rather than run from the server) So only when I use both (which I need). Here is the error I get in the server: Error during execution of task: JSONDecodeError('Expecting value: line 1 column 1 (char 0)') This is happening for task load_data[1], which I think corresponds to when item2 is supposed to be loaded to cosmos db. Any advice is appreciated.
    j
    Kevin Kho
    4 replies
    Copy to Clipboard
  • Amit Gupta

    Amit Gupta

    3 months ago
    Hey All, How to set database as cloud sql instead of sqlite in Prefect Kubernetes Setup?
    Amit Gupta
    Kevin Kho
    +1
    18 replies
    Copy to Clipboard
  • Guoying Qi

    Guoying Qi

    3 months ago
    Hi there. Just install Prefect 2.0b6 on my laptop and API and UI server work perfect fine locally. After I register the cloud, and login successful from the command line, and then tried to run some flows, got the following error:
    prefect.exceptions.PrefectHTTPStatusError: Client error '400 Bad Request' for url 'https://*******************************'
    Response: {'detail': 'Request specified API version 0.5.0 but this server only supports version 0.6.0 and below.'}
    For more information check: <https://httpstatuses.com/400>
    Which version of the Prefect I should install on my local machine? thanks.
    Guoying Qi
    Kevin Kho
    3 replies
    Copy to Clipboard
  • Guoying Qi

    Guoying Qi

    3 months ago
    For both 2.0b6 and 2.0b7, when you type http://127.0.0.1:4200/ in your browser, it will direct the url to http://127.0.0.1:4200/runs And then click around for runs, flows and deployments side menus, all work fine. But when you refresh the page with any addresses: http://127.0.0.1:4200/runs http://127.0.0.1:4200/flows http://127.0.0.1:4200/deployments it will return the following json:
    {
      "detail": "Not Found"
    }
    Guoying Qi
    Kevin Kho
    +1
    9 replies
    Copy to Clipboard