• y

    Yusuf Khan

    8 months ago
    I have a task failing with following error:Unexpected error: ValueError('ctypes objects containing pointers cannot be pickled') Before making this a prefect flow script it was executing fine. Its a small script running on a rasberry pi using the PiCamera module. There are other non-dependent tasks that are working alright. Any thoughts from anyone? Googling this didn't yield much
    y
    Kevin Kho
    2 replies
    Copy to Clipboard
  • Son Nguyen

    Son Nguyen

    8 months ago
    Hi, I’m launching a new Prefect server with
    prefect server start
    and everything started correctly. But in the UI, when I click into a flow, it’s not redirected to flow detail page. It looks like the following docker images version introduced a new bug
    prefecthq/apollo              core-0.15.12   d8519b0544d0   5 days ago     324MB
    prefecthq/server              core-0.15.12   d828f40dbf19   5 days ago     403MB
    prefecthq/ui                  core-0.15.12   5edd4fee96ed   3 weeks ago    225MB
    because it worked fine with this version
    prefecthq/ui                  core-0.15.11   6fac027b4605   4 weeks ago     225MB
    prefecthq/server              core-0.15.11   f6280189d6a5   6 weeks ago     402MB
    prefecthq/apollo              core-0.15.11   d1b07b3c9a57   6 weeks ago     324MB
    Son Nguyen
    Anna Geller
    8 replies
    Copy to Clipboard
  • a

    Akharin Sukcharoen

    8 months ago
    How can I fix the twice run scheduling? It make my server overload. Thank you in advance.
    a
    Anna Geller
    8 replies
    Copy to Clipboard
  • Emma Rizzi

    Emma Rizzi

    8 months ago
    Hi! Do you have any idea of what is causing this error :
    Failed to load and execute Flow's environment: FlowStorageError("An error occurred while unpickling the flow:\n  TypeError('an integer is required (got type bytes)')\nThis may be due to one of the following version mismatches between the flow build and execution environments:\n  - prefect: (flow built with '0.15.10', currently running with '0.15.12')\n  - python: (flow built with '3.7.11', currently running with '3.9.9')")
    ? I search this slack for insights, I use prefect Cloud with a docker agent on a VM, I upgraded prefect to 0.15.12 on both agent and development machine
    Emma Rizzi
    Anna Geller
    6 replies
    Copy to Clipboard
  • Malthe Karbo

    Malthe Karbo

    8 months ago
    Hi everyone, I am having some trouble using the DaskExecutor with Fargate mode. I get the following error (after successfully running all flows):
    RuntimeError: IOLoop is closed
    Flow example in thread and pinned versions as well
    Malthe Karbo
    Anna Geller
    +1
    59 replies
    Copy to Clipboard
  • a

    Aaron Pickering

    8 months ago
    Hi everyone, I'm trying to use "SnowflakeQueriesFromFile" in a task and I'm getting a strange error. Not sure how to start debugging this, any ideas? Could it be something to do with the file path?
    "Failed to load and execute Flow's environment: FlowStorageError('An error occurred while unpickling the flow:\n NameError("name \'err\' is not defined")')"
    The task itself is straightforward, it looks like this:
    snowsql_obj = SnowflakeQueriesFromFile(account=SNOWFLAKE_ACCOUNT, user=SNOWFLAKE_USER, password=SNOWFLAKE_PWD, file_path="../../sql/amplitude_raw.sql")
    snowsql_obj.run()
    a
    Anna Geller
    6 replies
    Copy to Clipboard
  • Samay Kapadia

    Samay Kapadia

    8 months ago
    Hey all. Where can I find a prefect configuration reference page? Googling “prefect configuration reference” takes me to the core concepts page, which doesn’t actually tell me what configurations I can actually change
    Samay Kapadia
    Kevin Kho
    7 replies
    Copy to Clipboard
  • Konstantin

    Konstantin

    8 months ago
    Hey all, please tell me how to set up the task launch sequence. For example at me one task deletes the data, the second task interposes the data. I need to run the delete first, and after insert data
    Konstantin
    Kevin Kho
    2 replies
    Copy to Clipboard
  • j

    Johan Wåhlin

    8 months ago
    hi all, I'm on a self hosted prefect server 15.11 running on AKS using the KubernetesRun() config, trying to create an Dask-cluster to use with the DaskExecutor. My flow works fine with a local cluster, however, as soon as I try to use an external cluster (using KubeCluster or Coiled) the flow stops with a message that "terminal tasks are incomplete" (see image). An hour or so later, the entire process failed with a connection-failed to my graphql-adress. Does this sound familiar to anyone?
    j
    Kevin Kho
    3 replies
    Copy to Clipboard
  • Samay Kapadia

    Samay Kapadia

    8 months ago
    Why would I get
    The secret KUBERNETES_API_KEY was not found
    if I’m running the prefect agent inside the cluster? According to this doc it will attempt an in cluster connection but my hello world task seems to keep failing 😭
    Samay Kapadia
    Kevin Kho
    4 replies
    Copy to Clipboard